码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3033 I love sneakers!分组背包

时间:2014-06-25 08:09:58      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   blog   code   http   

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3033

Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.
bubuko.com,布布扣

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
 

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn‘s demands can’t be satisfied.
 

Sample Input
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 

Sample Output
255

分组背包

代码如下:

#include <cstdio>
#include <cstring>
int max(int a,int b)
{
    if(a > b)
        return a;
    return b;
}
struct M
{
    int m,v;
}m[17][147];
int main()
{
    int i,j,k,KK,N,MM;
    int num[147],dp[11][10047];
    int vv,mm;
    while(~scanf("%d%d%d",&N,&MM,&KK))
    {
        memset(num,0,sizeof(num));
        memset(dp,-1,sizeof(dp));
        for(i = 0 ; i < N ; i++)
        {
            scanf("%d%d%d",&k,&mm,&vv);
            m[k][num[k]].m = mm;
            m[k][num[k]].v = vv;
            num[k]++;
        }
        for( i = 0 ; i <= MM ;i++)
        {
            dp[0][i] = 0;
        }
        for(k = 1 ; k <= KK ; k++)
        {
            for( i = 0 ; i < num[k] ; i++)
            {
                for(j  = MM ; j >= m[k][i].m ; j--)
                {
                    if(dp[k][j-m[k][i].m] != -1)
                    {
                        dp[k][j] = max(dp[k][j],dp[k][j-m[k][i].m]+m[k][i].v);
                    }
                    if(dp[k-1][j-m[k][i].m] != -1)
                    {
                        dp[k][j] = max(dp[k][j],dp[k-1][j-m[k][i].m]+m[k][i].v);
                    }
                }
            }
        }
        if(dp[KK][MM] == -1)
            printf("Impossible\n");
        else
            printf("%d\n",dp[KK][MM]);
    }
    return 0;
}


hdu3033 I love sneakers!分组背包,布布扣,bubuko.com

hdu3033 I love sneakers!分组背包

标签:des   style   class   blog   code   http   

原文地址:http://blog.csdn.net/u012860063/article/details/34134243

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!