码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1069 Monkey and Banana(最大的单调递减序列啊 dp)

时间:2015-07-16 22:23:48      阅读:313      评论:0      收藏:0      [点我收藏+]

标签:dp   hdu   最大的单调递减序列   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1069


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source

题意:

把给定的长方体(不限)叠加在一起,叠加的条件是,上面一个长方体的长和宽都比下面长方体的长


和宽短;求这些长方体能叠加的最高的高度.(其中(3,2,1)可以摆放成(3,1,2)、(2,1,3)等).

PS:
每块积木最多有 3 个不同的底面和高度,我们可以把每块积木看成三个不同的积木,
那么n种类型的积木就转化为3 * n个不同的积木,对这3 * n个积木的长按照从大到小排序;
然后找到一个递减的子序列,使得子序列的高度和最大。
代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
struct node
{
    int l, w, h;
} a[1047];
bool cmp(node a, node b)
{
    if(a.l == b.l)
    {
        return a.w > b.w;
    }
    return a.l > b.l;
}
int MAX(int a, int b)
{
    if(a > b)
        return a;
    return b;
}
int dp[1047];//dp[i]:以第i块积木为顶的最大高度
int main()
{
    int n;
    int cas = 0;
    while(scanf("%d",&n) && n)
    {
        //int L, W, H;
        int tt[3];
        int k = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d%d",&tt[0],&tt[1],&tt[2]);
            sort(tt,tt+3);
            a[k].l = tt[0];
            a[k].w = tt[1];
            a[k].h = tt[2];
            k++;
            a[k].l = tt[1];
            a[k].w = tt[2];
            a[k].h = tt[0];
            k++;
            a[k].l = tt[0];
            a[k].w = tt[2];
            a[k].h = tt[1];
            k++;
        }
        sort(a,a+k,cmp);
        int maxx = 0;
        for(int i = 0; i < k; i++)
        {
            dp[i] = a[i].h;
            for(int j = i-1; j >= 0; j--)
            {
                if(a[j].l>a[i].l && a[j].w>a[i].w)
                {
                    dp[i] = MAX(dp[i], dp[j]+a[i].h);
                }
            }
            if(dp[i] > maxx)
            {
                maxx = dp[i];
            }
        }
        printf("Case %d: maximum height = %d\n",++cas,maxx);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1069 Monkey and Banana(最大的单调递减序列啊 dp)

标签:dp   hdu   最大的单调递减序列   

原文地址:http://blog.csdn.net/u012860063/article/details/46916233

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!