码迷,mamicode.com
首页 > 其他好文 > 详细

uva 674 (入门DP, 14.07.09)

时间:2014-07-10 21:12:39      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:style   color   strong   os   cti   for   

  Coin Change 

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input 

11
26

Sample Output 

4
13

AC代码:

#include<stdio.h>
#include<string.h>

int cent[5] = {1, 5, 10, 25, 50};

int main() {
	long long dp[8000] = {1};

	for(int i = 0; i < 5; i++) {
		for(int j = 0; j < 8000-100; j++) {
			dp[j + cent[i]] += dp[j];
		}
	}
	int n;
	while(scanf("%d", &n) != EOF) {
		printf("%lld\n", dp[n]);
	}
	return 0;
}



uva 674 (入门DP, 14.07.09),布布扣,bubuko.com

uva 674 (入门DP, 14.07.09)

标签:style   color   strong   os   cti   for   

原文地址:http://blog.csdn.net/qq297060023/article/details/37609727

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!