码迷,mamicode.com
首页 > 其他好文 > 详细

简单概率DP——hdu4405

时间:2014-05-04 09:18:42      阅读:321      评论:0      收藏:0      [点我收藏+]

标签:hdu4405   概率dp   c++   算法   

题目描述:

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0.
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
1.1667 2.3441
很简单的概率dp题,几行代码搞定,也很容易理解,贴上代码,算是我的概率DP入门题:

/*******************************************************************************/
/* OS           : Linux fc20.x86_64 #1 SMP Tue Dec  UTC 2013 x86_64  GNU/Linux
 * Compiler     : 4.8.2 20131212 (Red Hat 4.8.2-7) (GCC)
 * Encoding     : UTF8
 * Date         : 2014-04-02
 * All Rights Reserved by alop.
*****************************************************************************/
/* Description: ***************************************************************
*****************************************************************************/
/* Analysis: ******************************************************************
*****************************************************************************/
/*****************************************************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
#define N 100005
int x[N],y[N],mp[N];
double dp[N];
int main()
{
     //freopen("input.txt","r",stdin);
    //freopen("output.txt","w",stdout);
   int n,m;
   while(cin>>n>>m&&(n||m))
   {
       int i=0;
       memset(mp,-1,sizeof(mp));
       memset(dp,0,sizeof(dp));
       while(i++<m)
       {
           cin>>x[i]>>y[i];
           mp[x[i]]=y[i];
       }
       for(i=n-1;i>=0;i--)
       {
           if(mp[i]!=-1)dp[i]=dp[mp[i]];
           else
           {
               for(int j=1;j<=6;j++)
                dp[i]+=dp[i+j];
               dp[i]=dp[i]/6+1;
           }
       }
       printf("%.4f\n",dp[0]);

   }
   return 0;
}




简单概率DP——hdu4405,布布扣,bubuko.com

简单概率DP——hdu4405

标签:hdu4405   概率dp   c++   算法   

原文地址:http://blog.csdn.net/alop_daoyan/article/details/24932709

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!