码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2602 Bone Collector(背包问题)

时间:2015-08-12 10:17:15      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:hdu2602   hdu 2602   01背包   dp   

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 39612    Accepted Submission(s): 16412


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
技术分享

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 

Author
Teddy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1203 2159 2955 1171 2191 
 

Statistic | Submit | Discuss | Note

非常常规的0 1背包问题。

第一排输入的是价值,第二排是体积

#include <stdio.h>
#include <string.h>
int main()
{
	int n,v;
	int ncase,dp[1005],val[1005],vol[1005];
	scanf("%d",&ncase);
	while(ncase--)
	{
		memset(dp,0,sizeof(dp));
		memset(val,0,sizeof(val));
		memset(vol,0,sizeof(vol));
		scanf("%d %d",&n,&v);
		for(int i=0;i<n;i++)
		scanf("%d",&val[i]);
		for(int i=0;i<n;i++)
		scanf("%d",&vol[i]);
		int max=0;
		for(int i=0;i<n;i++)
		{
			for(int j=v;j>=vol[i];j--)
			{
				if(dp[j]<dp[j-vol[i]]+val[i])
				dp[j]=dp[j-vol[i]]+val[i];
				if(dp[j]>max)
				max=dp[j];
			}
		}
		printf("%d\n",max);
	}
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

hdu2602 Bone Collector(背包问题)

标签:hdu2602   hdu 2602   01背包   dp   

原文地址:http://blog.csdn.net/su20145104009/article/details/47439157

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!