码迷,mamicode.com
首页 > 移动开发 > 详细

HDU 2767 Proving Equivalences (强联通)

时间:2014-07-12 18:14:35      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:图论   强联通   

http://acm.hdu.edu.cn/showproblem.php?pid=2767

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2926    Accepted Submission(s): 1100


Problem Description
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.
2. Ax = b has exactly one solution for every n × 1 matrix b.
3. Ax = b is consistent for every n × 1 matrix b.
4. Ax = 0 has only the trivial solution x = 0. 

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?
 

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.
 

Output
Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.
 

Sample Input
2 4 0 3 2 1 2 1 3
 

Sample Output
4 2
 

Source
 


题意:

要证明等价性(要求所有命题都是等价的),现已给出部分证明(u->v),问最少还需多少步才能完成目标。


分析:

我们的目标是(没有蛀牙)使得整个图是强联通的,已经有部分有向边u->v。我们先用强联通缩点,得到一个有向无环图,设入度为0的点有a个,出度为0的点有b个,我们只要max(a,b)步就能完成目标(数学归纳法可证)。


#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
#define sqr(x) ((x)*(x))
#define LL long long
#define itn int
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10
#define maxm 50000
#define maxn 20007

using namespace std;

int in[maxn],out[maxn];
int fir[maxn];
int u[maxm],v[maxm],nex[maxm];
int sccno[maxn],pre[maxn],low[maxn];
int st[maxn],top;
int scc_cnt,dfs_clock;
int n,m;

void tarjan_dfs(int _u)
{
    pre[_u]=low[_u]=++dfs_clock;
    st[++top]=_u;
    for (int e=fir[_u];~e;e=nex[e])
    {
        int _v=v[e];
        if (!pre[_v])
        {
            tarjan_dfs(_v);
            low[_u]=min(low[_u],low[_v]);
        }
        else
        {
            if (!sccno[_v])
            {
                low[_u]=min(low[_u],pre[_v]);
            }
        }
    }

    if (pre[_u]==low[_u])
    {
        ++scc_cnt;
        while (true)
        {
            int x=st[top--];
            sccno[x]=scc_cnt;
            if (x==_u) break;
        }
    }
}

void find_scc()
{
    scc_cnt=dfs_clock=0;top=-1;
    memset(pre,0,sizeof pre);
    memset(sccno,0,sizeof sccno);
    for (int i=1;i<=n;i++)
    {
        if (!pre[i])    tarjan_dfs(i);
    }
}

int main()
{
    #ifndef ONLINE_JUDGE
        freopen("/home/fcbruce/文档/code/t","r",stdin);
    #endif // ONLINE_JUDGE

    int T_T;
    scanf("%d",&T_T);
    while (T_T--)
    {

        scanf("%d %d",&n,&m);
        memset(fir,-1,sizeof fir);
        for (itn i=0;i<m;i++)
        {
            scanf("%d %d",&u[i],&v[i]);
            nex[i]=fir[u[i]];
            fir[u[i]]=i;
        }

        find_scc();

        if (scc_cnt==1)
        {
            printf("%d\n",0);
            continue;
        }

        memset(in,0,sizeof in);
        memset(out,0,sizeof out);
        for (int i=0;i<m;i++)
        {
            if (sccno[u[i]]==sccno[v[i]])   continue;

            in[sccno[v[i]]]++;
            out[sccno[u[i]]]++;
        }

        int a=0,b=0;
        for (itn i=1;i<=scc_cnt;i++)
        {
            if (in[i]==0)   a++;
            if (out[i]==0)  b++;
        }

        printf("%d\n",max(a,b));
    }


    return 0;
}


HDU 2767 Proving Equivalences (强联通),布布扣,bubuko.com

HDU 2767 Proving Equivalences (强联通)

标签:图论   强联通   

原文地址:http://blog.csdn.net/u012965890/article/details/37669347

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!