码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 3822 Domination(概率dp)

时间:2014-10-12 23:49:08      阅读:241      评论:0      收藏:0      [点我收藏+]

标签:zju   zoj   牡丹江   dp   概率dp   

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5376


Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What‘s more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That‘s interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= NM <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

Author: JIANG, Kai


PS:

附上bin神的概率dp总结 Orz;

http://www.cnblogs.com/kuangbin/archive/2012/10/02/2710606.html


代码如下:(学习:http://blog.csdn.net/napoleon_acm/article/details/40020297

//dp[i][j][k] 表示当前用了<=k个chess ,覆盖了i行j列(i*j的格子 每行至少一个,每列至少一个)的概率。
//
//dp[i][j][k] 由 dp[i][j][k-1] , dp[i-1][j][k-1], dp[i][j-1][k-1], dp[i-1][j-1][k-1]得到,
//分别表示 1、添加的新的一个chess, 2、不覆盖新的行列, 3、只新覆盖一行, 只新覆盖一列,
//4、同时新覆盖一行和一列,得到dp[i][j][k]。
//递推时, 每个概率 * (可以覆盖的点数/剩余所有的空点数) 相加得到[i][j][k].
//ans += (dp[n][m][i] - dp[n][m][i-1])* i;  (i = [1, n*m])
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 57;
double dp[maxn][maxn][maxn*maxn];
int main()
{
    int n, m;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(dp,0,sizeof(dp));
        dp[0][0][0] = 1.0;
        for(int i = 1; i <= n; i++)
        {
            for(int j =1; j <= m; j++)
            {
                for(int k = 1; k <= n*m; k++)
                {
                    dp[i][j][k] = dp[i][j-1][k-1]*((1.0*i*(m-j+1))/(n*m-k+1))
                                  +dp[i-1][j][k-1]*((1.0*(n-i+1)*j)/(n*m-k+1))
                                  +dp[i-1][j-1][k-1]*((1.0*(n-i+1)*(m-j+1))/(n*m-k+1))
                                  +dp[i][j][k-1]*((1.0*(i*j-k+1))/(n*m-k+1));
                }
            }
        }
        double ans = 0;
        for(int i = 1; i <= n*m; i++)
        {
            ans+=(dp[n][m][i]-dp[n][m][i-1])*i;
        }
        printf("%.12lf\n",ans);
    }
    return 0;
}



ZOJ 3822 Domination(概率dp)

标签:zju   zoj   牡丹江   dp   概率dp   

原文地址:http://blog.csdn.net/u012860063/article/details/40022465

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!