码迷,mamicode.com
首页 > 其他好文 > 详细

1001 A+B Format

时间:2019-12-24 23:42:32      阅读:89      评论:0      收藏:0      [点我收藏+]

标签:wrap   ram   ble   space   nowrap   pair   input   div   html   

1001 A+B Format (20分)
 

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

题解:这里所说的每三个数字中间添加一个‘,’是指从右边的第一个数字开始数,每三个数字添加一个‘,’。有时间的话还是要把那本《C++ prime plus》再看一遍,很多C++的基础语法都忘了=_=

 

#include<iostream>
using namespace std;

int main() {
    int a, b;

    cin >> a >> b;

    string s = to_string(a+b);
    int len = s.length();

    for (int i = 0; i < len; ++i) {
        cout << s[i];
        
        if (s[i] == ‘-‘) continue;

        if ((i + 1) % 3 == len % 3 && i != len - 1)
            cout << ‘,‘;
    }

    cout << endl;
    return 0;
}

  

1001 A+B Format

标签:wrap   ram   ble   space   nowrap   pair   input   div   html   

原文地址:https://www.cnblogs.com/ruruozhenhao/p/12093906.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!