码迷,mamicode.com
首页 > 其他好文 > 详细

杭电oj1859:最小长方形(水题)

时间:2020-02-02 20:04:47      阅读:73      评论:0      收藏:0      [点我收藏+]

标签:class   esc   tps   pac   https   names   cin   没有   The   

最小长方形

题目链接

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description
给定一系列2维平面点的坐标(x, y),其中x和y均为整数,要求用一个最小的长方形框将所有点框在内。长方形框的边分别平行于x和y坐标轴,点落在边上也算是被框在内。

Input
测试输入包含若干测试用例,每个测试用例由一系列坐标组成,每对坐标占一行,其中|x|和|y|小于 231;一对0 坐标标志着一个测试用例的结束。注意(0, 0)不作为任何一个测试用例里面的点。一个没有点的测试用例标志着整个输入的结束。

Output
对每个测试用例,在1行内输出2对整数,其间用一个空格隔开。第1对整数是长方形框左下角的坐标,第2对整数是长方形框右上角的坐标。

Sample Input
12 56
23 56
13 10
0 0
12 34
0 0
0 0

Sample Output
12 10 23 56
12 34 12 34
技术图片

#include<iostream>
using namespace std;

int main()
{
    //freopen("in.txt","r", stdin);
    int maxX=-232, minX=232, maxY = -232, minY = 232;
    int x, y, flag = 0;;
    while(cin>>x>>y)
    {
        if(x==0 && y==0 && flag)
        {
            flag = 0;
            cout<<minX<<" "<<minY<<" "<<maxX<<" "<<maxY<<endl; 
            maxX = maxY =-232;
            minX = minY = 232;
            continue;
        }
        flag = 1;
        minX = x < minX ? x : minX;
        minY = y < minY ? y : minY;
        maxX = x > maxX ? x : maxX;
        maxY = y > maxY ? y : maxY;
        
    }
    return 0;
}

杭电oj1859:最小长方形(水题)

标签:class   esc   tps   pac   https   names   cin   没有   The   

原文地址:https://www.cnblogs.com/SYDong/p/12253153.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!